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ABOUT THIS USER GUIDE 

This guide is a step by step guide on how to install, use and remove the OPC UA Server 

Simulator.  

The OPC UA Server Simulator simulates real-time data for a configurable set of tags and values, 
used for testing purposes. The simulated data is then stored in the memory level enabling the 
simulator to respond to historical data read requests from OPC UA client applications.  
 

OPERATING SYSTEMS COMPATIBILITY 
 This OPC UA Server Simulator supports the following operating systems:  

• Windows 10  

• Windows 8  

• Windows 7 

• Windows Server 2019 

• Windows Server 2016  

• Windows Server 2012  

• Windows Server 2008 
 

INSTALLATION PRE-REQUISITES 

In order to properly run the OPC UA Server Simulator, you must install these software 
components on the target system: 

• Microsoft .NET Framework version 4.6.1 or later. 

INSTALLING OPC UA SERVER SIMULATOR 

Execute the « IntegrationObjects'OPCUAServerSimulator_1.2.0 » program on your machine 

using an administrator account. The installation wizard will take you through the different steps. 

 

1. Right click on the downloaded installation package for OPC UA server Simulator and 

select “Run as administrator” from the displayed menu. The installation welcome dialog 

box will appear. 
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Figure 1: Installation Welcome Dialog 

 

 

2. Click the Next button. The license agreement will be displayed. 
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Figure 2: License Agreement Dialog 

 

3. After reading the license agreement, select the first option and click the Next button. By 

proceeding, you are accepting all of the license agreement terms. Otherwise, you can 

cancel the installation. The customer information dialog box will appear.   
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Figure 3: Customer Information Dialog 

 

 

4. Add the user name and the company name and then click the Next button. The dialog 

box for choosing the deployment version will be displayed.  
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Figure 4: Choose Deployment Version Dialog Box 

 

5. After selecting the OPC UA Server deployment version, the dialog box for choosing the 

destination folder will be displayed. 

 

6. Click the Next button to use the default destination folder and continue the installation, or 

the Browse button to select a different destination folder. The installation dialog box will 

then appear.   

 

7. Click the Next button to continue with the installation of the OPC UA Local Discovery 

Sever if it is not already installed. The dialog box for choosing to install the UA Local 

Discovery Server will be displayed as illustrated below.  
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Figure 5: OPC UA Local Discovery Server 

 

To install the OPC UA Local Discovery Server: 

1. Select it, then click next: 
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        Figure 6: Installation UA Local Discovery Welcome Dialog 

 

2. Click next, the license agreement will be displayed: 

 
                        Figure 7: UA Local Discovery License Agreement Dialog 
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3. After reading the license agreement, select the first option and click the Next button. 

Then click finish. 

 

 

 
     Figure 8:UA Local Discovery Installation Completed Dialog 

 

 

 

 

 

 

 

 

 

8. Click the Finish button to complete the installation. 

 

 

 

Note that the simulator needs to be registered with the Local Discovery Server(LDS) which 
collects and publishes information about UA servers in order to enable the OPC UA clients to 
read the information about the registered OPC UA servers from the LDS. 
 
For more information about Local Discovery Server, see the OPC Unified Architecture 
Specification Part 12. 
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           Figure 9: Installation Completed Dialog 

 

Once the installation is completed, you can start the OPC UA Server Simulator as follows: 

1. Go to Start → Programs → Integration Objects → OPC UA Server Simulator  

2. Start the OPC UA Server Simulator using an administrator account. 

 

 

         Figure 10: OPC UA Server Simulator Start Menu 
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The OPC UA Server Simulator includes a 48 hour runtime period for all features. The count for 

the 48 hours starts when you start the simulator. When this period times out, you only need to 

restart the simulator. 

 

Figure 11: OPC UA Server Simulator – Message Box 

 

USING THE MAIN USER INTERFACE 

The main user interface of the simulator is illustrated in the figure below: 

 

 

Figure 12: OPC UA Server Simulator - Main User Interface 
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The user interface displays general information about OPC UA Server Simulator, which are: 

• Server Endpoint URLs 

• Sessions information 

o Session ID 

o Session Name 

o User ID 

o Last Contact Time 

• Subscriptions information 

o Subscription ID 

o Publishing Interval 

o Item Count 

o Sequence Number 

• Server Status 

• Total Subscriptions 

• Total Sessions 

• Total items 

• Current Time 

 

 

 

The server menu contains 3 items (File, Settings and Help) as shown in the following 

screenshot: 

 

• Click on "File →Exit" to request all connected clients to disconnect and close the server. 

 

 

               Figure 13: Exit Menu Item 

 

 

• Click on "Settings→Security Policies" to go to the security policies settings user 

interface. 

   

 

                  Figure 14:  Security Policies Menu Item 
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• Click on "Settings→Configuration" to go to the configuration settings user interface. 

 

 
                                Figure 15:  Configuration Menu Item 

 

 

• Click on "Help→Quick User Guide" to view the quick user guide . 

 

 

 

                 Figure 16:  Quick User Guide Menu Item 

 

• Click on "Help→About” to get more information about the product.  

 

 

Figure 17: About Menu Item 

 

CONFIGURING THE SECURITY POLICIES SETTINGS  

In the Security Policies user interface, you can select a security mode to be associated with the 

OPC UA Server Simulator to instruct the OPC UA client to open a secure channel with it. Only 

the checked security modes in the user interface below will be available to the OPC UA client. 
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Figure 18:  Security Settings  User Interface 

 

 

USING THE CONFIGURATION SETTINGS  

In the Configuration Settings user interface, you can configure the port numbers and the server 

names for TCP and HTTPS connections. You can also change the update rate in milliseconds, 

which is the data simulation frequency. 
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                          Figure 19:  Configuration Settings  User Interface 

USING THE CSV SIMULATION FILES 

The OPC UA Server Simulator uses 2 CSV simulation files: 

• « AddressSpace.csv» used to build the address space of the OPC UA Server. 

• « ValueSpace.csv» used to simulate the data values of the OPC UA items. 

 

Those two files are located at the following path: 
 X:\Program Files (x86)\Integration Objects\Integration Objects' OPC UA Server 
Simulator\OPC UA Server Simulator\DATA 
 

 
 

 

 
 

 
 

Note that X identifies the local disk where the OPC UA Server Simulator is installed. 
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The default files are illustrated in the figures below: 

 

• Address Space file 
 

                            

                 Figure 20: Address Space File 

 
The “AddressSpace.csv” file is composed of the following fields: 

 

• Tag Name: The name of the tag. 

• Data Type: The OPC UA Server supports the following data types: 

✓ IO_Int16 

✓ IO_Int32 

✓ IO_Int64 

✓ IO_UInt16 

✓ IO_UInt32 

✓ IO_UInt64 

✓ IO_Double 

✓ IO_String 

✓ IO_Byte 

✓ IO_Boolean 
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• Access Rights: The access rights of the tag. 

• Simulated: A Boolean field that indicates if the tag values are simulated or not. For the 

simulated tags, you can specify the data values to be used for the simulation using the 

“ValueSpace.csv”. Otherwise, the simulator will assign random data values. 

 
 
 
 

 
 

• Value Space file 

               
      Figure 21: Value Space File 

 

The “ValueSpace.csv” file includes the data values and qualities to be simulated for the tags 

listed in the "AddressSpace.csv” file.  

 

There are 2 columns for each tag in the “ValueSpace.csv” file: 

• The first column starts with the name of the tag then the simulation type of the tag and 

finally the several data values, 

• The second column starts with an empty row and then the values qualities. 

 

In other words, the CSV format is as follows: 

• The first line indicates the tag names. Each tag name cell should be followed by an 

empty cell. 

• The data values and qualities should be specified starting from the second line.  Each 

couple of columns relates to one tag and is organized as: 

o The first column lists the tag values.  

Note that the tag values list is only allowed when “Simulated” attribute is set to 

true in the AddressSpace.csv csv file.  

o The second column lists the quality of each value. 

 

Note that all unsupported data types will be converted to string. 
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As previously indicated, the “ValueSpace.csv” file should include the data of the 
"AddressSpace.csv” file to be simulated. Note that you do not have to include all of them. You 
can include only the ones for which you have a specific data set to simulate. 

 

 

 

 

 

CONNECTING OPC UA SERVER SIMULATOR 

 To connect to the OPC UA Simulator, you can: 
- Open an OPC UA Client, click Discover button and then select the server endpoint’s 

URL from the discovered servers list. 
 

               

                                                    Figure 22: Discover Button of the OPC UA Client 

 

 

      Figure 23: The discovered servers list 

 
- Or simply Copy the server’s endpoint URL and paste it in the Endpoint URL field of the 

OPC UA Client. 
 

 

      Figure 24: OPC UA Server Endpoints URLs 

 

 

Note that the simulator keeps by default 120 seconds of historical data per Tag. This duration 
could be set by changing “ArchiveLimit” parameter from the “OPCUAServerConfig.ini” 
configuration file located in the installation folder: 
X:\Program Files (x86)\Integration Objects\Integration Objects' OPC UA Server Simulator\OPC 
UA Server Simulator\ 
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REMOVING OPC UA SERVER SIMULATOR 

To uninstall the OPC UA Server Simulator, follow the steps below: 

1. Click the “Uninstall UA Server Simulator” shortcut available in the start menu, as 
shown in the figure below: 

 

Figure 25: Uninstall Shortcut in the Start Menu 

 
The following dialog box will appear: 

 

 

Figure 26: Uninstall the OPC UA Server Simulator 

2. Click the Yes button to start uninstalling.  

3. The wizard will then take you through the removal steps. At the end, click Finish when 
the un-installation is complete.  

 

 

 

If you are using Windows 10, Windows Server 2012 or Windows Server 2016 operating 
system, the uninstaller needs to be run from the start menu as shown below. 
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Figure 27: Windows 10 Startup Menu Uninstall Shortcut  

 

 

 

The OPC UA Server Simulator can also be manually removed as follows:  

1. Go to the Control Panel.  

2. Click Programs and Features  

3. In the Programs and Features dialog screen, select Integration Objects’ OPC UA 
Server Simulator.  

4. Click Uninstall then OK. 
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For additional information on this guide, questions or problems to report, please contact: 
 

Offices 
- Americas:    +1 713 609 9208 
- Europe-Africa-Middle East: +216 71 195 360 
 
Email 
- Support Services: customerservice@integrationobjects.com 
- Sales: sales@integrationobjects.com 

 
To find out how you can benefit from other Integration Objects products and custom-designed 
solutions, please visit us on the Internet: 
 

Online 
- www.integrationobjects.com 
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